Zugriff auf Wibutler über VPN


  • Tach zusammen,
    muß bei der Konfiguration eines IPSec-VPN-Tunnels irgendetwas besonderes beachtet werden? Ich habe zwischen einem Android Handy und einem Lancom-Router ein Tunnel eingerichtet, der grundsätzlich auch funktioniert. Der Tunnel wurde nach dieser Anleitung eingerichtet:
    https://www2.lancom.de/kb.nsf/1275/5B38E5A461433B26C1257A33002B4B72?OpenDocument
    Ich erreiche allerdings den Wibutler über die App nicht. Die Verbindung wird nicht aufgebaut. Andere appbasierten Anwendungen funktionieren über den Tunnel. Auch kann ich den Wibutler über den Browser auf Port 8080 erreichen. Ohne VPN ist der Wibutler über die HandyApp ganz normal erreichbar, daher denke ich, dass irgendetwas besonderes in der VPN-Verbindung konfiguriert werden muß. Auch mit ausgeschalteter Firewall ist der Wibutler über die App nicht erreichbar.
    Weiß jemand etwas?

    Vielen Dank
    Dedan

  • Hallo Dedan,

    blöde Frage (da ich kürzlich ein ähnliches Vorhaben und Problem hatte). Läuft Dein Provider auf "Full Dual Stack" oder nur "DS Lite"? D.h. vergeben sie deinem Router nur eine IPv6 Adresse? VPN geht aktuell durch den Umbruch IPv4 zu v6 nur mit einer IPv4 Adresse.

    http://www.computerwoche.de/a/ipv6-macht-vpns-probleme,3210854
    http://www.pcwelt.de/ratgeber/Trotz-IPV6-Zugriff-auf-das-Heimnetz-reparieren-9961065.html

    Da Du aber schreibst dass "der Tunnel grundsätzlich auch funktioniert" gehe ich davon aus, Du hast eine v4 Adresse mit einem DynDNS Dienst am laufen. Ich habe leider aufgrund eines Neuvertrages kein Glück, da ist eine v4 Adresse aufpreispflichtig mit 5 Euro im Monat, was es mir nicht wert ist.

    Es gibt aber auch günstigere Alternativen wie z.B. ein "externes" Mapping via Diensten wie feste-ip.net
    Hier vermittelt der Dienst zwischen deinem Clientgerät (IPv4) und deinem nur per IPv6 erreichbaren Heimanschluss.

    Falls Du eine IPv4 Adresse von Deinem Provider bekommst, versuch es mit einer Port forwarding-Regel im Router direkt auf den Wibutler :8080
    Ist eh performanter als die App finde ich.

    Viele Grüße,
    Thorsten

  • Hallo Thorsten,

    nein, an der IP-Adresse liegt es nicht, ich bekomme ja eine IPv4-Adresse. Über Port 8080, also über den Browser ist der Wibutler über den Tunnel ja auch erreichbar, aber ich möchte ja die App benutzen. Hier ist laut App der Port 48161 zuständig, aber auch ein PortForwarding hilft da leider nicht... Ist ja normalerweise auch nicht notwendig, da ich ja durch den Tunnel im selben Netzwerk bin, wie der WB.

    Viele Grüße
    Dedan

  • Noch etwas..
    während der Tunnel aufgebaut ist und ich mit der "manuellen Suche" den WB in der App suche, bekomme ich auch eine Meldung, dass der WB gefunden wurde. Nur leider wird dann die Verbindung nicht aufgebaut.

  • Hi Dedan,

    alles klar, dann gehörst Du noch zu den glücklichen DSL "Altverträgen" ;-)
    Zur App kann ich dann leider auch nicht weiterhelfen. Diese hat zwar auch bei mir im heimischen WLAN immer wieder mal Verbindungsprobleme und -abbrüche, zu Deinem VPN Problem kann ich aber leider auch nicht viel mehr beisteuern ;-)

    Letzter Schuß ins Blaue: die "Remote" Funktion ist aktiviert? Aber darum geht es Dir ja nicht - sondern, den WB via VPN quasi im Lokalnetz aufzurufen, was btw. bemerkt auch der sinnvollste Ansatz ist. Wie sicher der SSL Stack implementiert ist weiß man nicht, da ist VPN einfach die beste uns sicherste Lösung, keine Frage.

    Dann schauen wir mal, wer Dir weiterhelfen kann, das Thema "sicherer Fernzugriff aufs Smarthome" treibt mich ebenfalls um. Und ich traue keiner Black-Box Lösung, offen gestanden, schon gar nicht per Remotezugriff. Daher ist mein WB auch immer per harter Blockregel im Router "dicht" nach außen und wird nur hin und wieder zum Check auf Updates geöffnet...

    VG
    Thorsten

  • Also, nach weiteren Tests habe ich folgendes herausgefunden:
    Ist die WAN-Verbindung ein WLAN und darauf setzt der VPN auf, geht alles.
    Geht die WAN-Verbindung über LTE und darauf setzt der VPN auf, geht es nicht.
    Hat da vielleicht die App ein Routingproblem?
    Hierzu wäre eine Aussage des Wibutler-Suppots nicht schlecht.

    Vielen Dank
    Dedan